码迷,mamicode.com
首页 > 其他好文 > 详细

1019. 数字黑洞 (20)

时间:2017-03-19 16:08:15      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:apr   排序   否则   开始   sys   输入   ...   std   while   

1019. 数字黑洞 (20)

给定任一个各位数字不完全相同的4位正整数,如果我们先把4个数字按非递增排序,再按非递减排序,然后用第1个数字减第2个数字,将得到一个新的数字。一直重复这样做,我们很快会停在有“数字黑洞”之称的6174,这个神奇的数字也叫Kaprekar常数。

例如,我们从6767开始,将得到

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

现给定任意4位正整数,请编写程序演示到达黑洞的过程。

输入格式:

输入给出一个(0, 10000)区间内的正整数N。

输出格式:

如果N的4位数字全相等,则在一行内输出“N - N = 0000”;否则将计算的每一步在一行内输出,直到6174作为差出现,输出格式见样例。注意每个数字按4位数格式输出。

输入样例1:

6767

输出样例1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

输入样例2:

2222

输出样例2:

2222 - 2222 = 0000

 注意:0-0=0也需要输出一次

#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>

using namespace std;
 int  jian(int n)
{
    int a[4];
    a[0] = n / 1000;
    a[1] = n / 100 % 10;
    a[2] = n / 10 % 10;
    a[3] = n % 10;
    sort(a, a + 4);
    int big, small,temp;
    small = a[0] * 1000 + a[1] * 100 + a[2] * 10 + a[3];
    big=a[3] * 1000 + a[2] * 100 + a[1] * 10 + a[0];
    temp = big - small;
    if (big == temp) printf("%04d - %04d = %04d\n", big, small, temp);
    else
    {
        printf("%04d - %04d = %04d\n", big, small, temp);
    }
        return temp;

}







int main()
{
    int number;
    cin >> number;
    do{
        number = jian(number);
    } while (number != 6174 && number != 0);//0000-0000 = 0 需要输出一次
    

    system("pause");
    return 0;
}

 

1019. 数字黑洞 (20)

标签:apr   排序   否则   开始   sys   输入   ...   std   while   

原文地址:http://www.cnblogs.com/brightz2017/p/6580519.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!