码迷,mamicode.com
首页 > 其他好文 > 详细

1020. 月饼 (25)

时间:2017-03-19 16:16:41      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:pre   clu   math.h   class   ace   print   log   需求   精确   

1020. 月饼 (25)

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有3种月饼,其库存量分别为18、15、10万吨,总售价分别为75、72、45亿元。如果市场的最大需求量只有20万吨,那么我们最大收益策略应该是卖出全部15万吨第2种月饼、以及5万吨第3种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含1个测试用例。每个测试用例先给出一个不超过1000的正整数N表示月饼的种类数、以及不超过500(以万吨为单位)的正整数D表示市场最大需求量。随后一行给出N个正数表示每种月饼的库存量(以万吨为单位);最后一行给出N个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后2位。

输入样例:

3 20
18 15 10
75 72 45

输出样例:

94.50

#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <cstring>
#include <cstdio>
#include<algorithm>
#include<vector>

using namespace std;
struct mooncake
{
    float kucun;
    float zongshoujia;
    float danjia;
}cake[9999];

bool cmp(mooncake a, mooncake b)
{
    return a.danjia > b.danjia;
}

int main()
{
    int n;
    int need;
    cin >> n >> need;
    float income=0;
    for (int i = 0; i < n; i++)
    {
        cin >> cake[i].kucun;
    }
    for (int i = 0; i < n; i++)
    {
        cin >> cake[i].zongshoujia;
        cake[i].danjia = cake[i].zongshoujia / cake[i].kucun;
    }
    sort(cake, cake + n, cmp);
    int j = 0;
    while (need > 0&&j<n)
    {
        if (need > cake[j].kucun)
        {
            need -= cake[j].kucun;
            income += cake[j].zongshoujia;
        }
        else
        {
            income += cake[j].danjia*need;
            need = 0;
        }
        j++;
    }

    


    printf("%.2lf\n", income);
    system("pause");
    return 0;
}

 

1020. 月饼 (25)

标签:pre   clu   math.h   class   ace   print   log   需求   精确   

原文地址:http://www.cnblogs.com/brightz2017/p/6580521.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!