码迷,mamicode.com
首页 > 其他好文 > 详细

poj3071之概率DP

时间:2014-05-09 01:12:00      阅读:311      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   ext   

Football
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 2667   Accepted: 1361

Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then, the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 ? pji for all i ≠ j, and pii = 0.0 for all i. The end-of-file is denoted by a single line containing the number ?1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the double data type instead of float.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least 0.01.

Sample Input

2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output

2
/*分析:假设dp[i][j]表示进行第i次比赛j赢得概率
则主要在于计算第i次比赛可能与j相邻的队伍t并且本次是与t比赛 
然后dp[i][j]+=dp[i-1][j]*dp[i-1][t]*p[j][t]
对于t如何算?
假设队伍id:
0 1 2 3 4 5 6 7
对于第一轮比赛相对上一轮比赛:
0属于第一个赢家,1属于第二个赢家,2属于第三个赢家,3属于第四个赢家... 
第一次比赛后:
0/1 2/3 4/5 6/7
对于第二轮比赛相对上一轮比赛:
0/1属于第一个赢家,2/3属于第二个赢家...
可以发现规律都是:
第奇数个赢家和前一个赢家比赛
第偶数个赢家和后一个赢家比赛
也不难发现规律,对于第j个队伍在第i次比赛
属于第j/(2^(i-1))个赢家//从0开始 
*/
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#include <map>
#include <cmath>
#include <iomanip>
#define INF 99999999
typedef long long LL;
using namespace std;

const int MAX=(1<<7)+10;
const int N=10+10;
int n;
double p[MAX][MAX],dp[N][MAX];//dp[i][j]表示第i回合j胜利的概率

int main(){
	while(~scanf("%d",&n),n != -1){
		int bit=1<<n;
		for(int i=0;i<bit;++i){
			for(int j=0;j<bit;++j)scanf("%lf",&p[i][j]);
		}
		memset(dp,0,sizeof dp);
		for(int i=0;i<bit;++i)dp[0][i]=1;
		for(int i=1;i<=n;++i){
			for(int j=0;j<bit;++j){
				int t=j>>(i-1);//j经历i-1次属于第t个赢家 
				if(t&1){//j为奇数赢家,本次将与第j-1个赢家比赛 
					for(int k=t*(1<<(i-1))-1;k>=(t-1)*(1<<(i-1));--k){
						dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
					}
				}else{//j为偶数赢家,本次将与第j+1个赢家比赛 
					for(int k=(t+1)*(1<<(i-1));k<(t+2)*(1<<(i-1));++k){
						dp[i][j]+=dp[i-1][j]*dp[i-1][k]*p[j][k];
					}
				}
			}
		}
		int id=0;
		for(int i=0;i<bit;++i){
			if(dp[n][i]>dp[n][id])id=i;
		}
		printf("%d\n",id+1);
	}
	return 0;
}



poj3071之概率DP,布布扣,bubuko.com

poj3071之概率DP

标签:des   style   blog   class   code   ext   

原文地址:http://blog.csdn.net/xingyeyongheng/article/details/25338503

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!