码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 1385 Minimum Transport Cost

时间:2014-05-09 00:34:53      阅读:345      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   code   java   tar   


Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7007    Accepted Submission(s): 1791


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

Source
 


最基本的floyd最短路,难点在记录字典序最小的路径.....

有两种路径记录方法:

出始化: fa[a][b]=a 则 fa[a][b]=c 表示  a....c->b

出始化: fa[a][b]=b 则 fa[a][b]=c 表示  a->c....b

根据题意,要选择第二种


#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>

using namespace std;

const int INF=0x3f3f3f3f;

int n;
int g[110][110],b[110];
int fa[110][110];

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(g,63,sizeof(g));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&g[i][j]);
                if(g[i][j]==-1)
                    g[i][j]=INF;
            }
        }

        for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);

        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                fa[i][j]=j;

        for(int k=1;k<=n;k++)
        {
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=n;j++)
                {
                    if(g[i][j]>g[i][k]+g[k][j]+b[k])
                    {
                        g[i][j]=g[i][k]+g[k][j]+b[k];
                        fa[i][j]=fa[i][k];
                    }
                    else if(g[i][j]==g[i][k]+g[k][j]+b[k])
                    {
                        fa[i][j]=min(fa[i][j],fa[i][k]);
                    }
                }
            }
        }

        int s,t;
        while(scanf("%d%d",&s,&t)!=EOF)
        {
            if(s==-1&&t==-1) break;
            printf("From %d to %d :\nPath: ",s,t);
            int next=fa[s][t];
            printf("%d",s);
            if(s!=t)
            {
                while(next!=t)
                {
                    printf("-->");
                    printf("%d",next);
                    next=fa[next][t];
                }
                printf("-->%d",t);
            }
            printf("\nTotal cost : %d\n\n",g[s][t]);
        }
    }
    return 0;
}



HDOJ 1385 Minimum Transport Cost,布布扣,bubuko.com

HDOJ 1385 Minimum Transport Cost

标签:des   style   class   code   java   tar   

原文地址:http://blog.csdn.net/ck_boss/article/details/25337509

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!