码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1243 畅通工程 并査集

时间:2014-08-22 10:54:46      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   strong   for   ar   

Total Submission(s): 31033    Accepted Submission(s): 16313


Problem Description
某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。
注意:两个城市之间可以有多条道路相通,也就是说
3 3
1 2
1 2
2 1
这种输入也是合法的
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最少还需要建设的道路数目。
 

Sample Input
4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0
 

Sample Output
1 0 2 998
Hint
Hint



水题,就是把有关系的联系在一起,不解释



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 10005

int father[N];

int cha(int x)
{
    if(x!=father[x])
        father[x]=cha(father[x]);
    return father[x];
}

int main()
{
    int i,n,m;
    while(scanf("%d",&n),n)
    {
        scanf("%d",&m);

        for(i=1;i<=n;i++)
            father[i]=i;

        int x,y;

        while(m--)
        {
            scanf("%d%d",&x,&y);
            int xx=cha(x);
            int yy=cha(y);
            father[xx]=yy;
        }


        int ans=-1;
        for(i=1;i<=n;i++)
            if(father[i]==i)
            ans++;

        printf("%d\n",ans);
    }
    return 0;
}


HDU 1243 畅通工程 并査集,布布扣,bubuko.com

HDU 1243 畅通工程 并査集

标签:des   style   color   os   io   strong   for   ar   

原文地址:http://blog.csdn.net/u014737310/article/details/38751297

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!