码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2802 F(N)

时间:2014-08-22 10:55:16      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:水题   hdu   暴力打表   

F(N)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3408    Accepted Submission(s): 1171


Problem Description
bubuko.com,布布扣
Giving the N, can you tell me the answer of F(N)?
 

Input
Each test case contains a single integer N(1<=N<=10^9). The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output
For each test case, output on a line the value of the F(N)%2009.
 

Sample Input
1 2 3 0
 

Sample Output
1 7 20
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2807 2803 2804 2800 2806 
 

Statistic | Submit | Discuss | Note

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<stack>
#include<queue>
#include<set>
#include<map>
#include<vector>
#include<stdlib.h>
using namespace std;
typedef long long LL;
const LL MOD = 2009;
LL f[4050];
void init()
{
    f[1] = 1; f[2] = 7;
    for(LL i = 3;i <= 4018;i++)
    {
        f[i] = (f[i-2]%MOD+(((i*i*i)%MOD-((i-1)*(i-1)*(i-1))%MOD)+MOD)%MOD)%MOD;
    }
}//4018是循环节 4018^3 = 64,867,893,832超int所以用long long
int main()
{
    init();
    int N;
    while(scanf("%d",&N)&&N)
    {
        N = N%4018;
        printf("%d\n",f[N]);
    }
    return 0;
}


HDU 2802 F(N),布布扣,bubuko.com

HDU 2802 F(N)

标签:水题   hdu   暴力打表   

原文地址:http://blog.csdn.net/demonstrate8/article/details/38751185

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!