码迷,mamicode.com
首页 > 其他好文 > 详细

poj-2299 Ultra—QuickSort(归并排序求逆序数)

时间:2014-05-09 01:13:27      阅读:299      评论:0      收藏:0      [点我收藏+]

标签:逆序数   归并排序   

Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 38688   Accepted: 13950

Description

bubuko.com,布布扣In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9 1 0 5 4
3
1 2 3
0

Sample Output

6
0



思路:

      归并排序求逆序数,用作模版

代码:

#include <stdio.h>
#define lld I64d
#define LL __int64
#define N 1000050

LL num[N];
LL temp[N];  // 归并排序的辅助数组
LL count = 0;

void Merge(LL * array, int first, int middle, int last)
{
	int i = first, j = middle + 1, cur = 0;
	while(i <= middle && j <= last){
		if(array[i] < array[j])
			temp[cur ++] = array[i ++];
		else{
			temp[cur ++] = array[j ++];
			count += middle - i + 1;
		}
	}
	while(i <= middle)
		temp[cur ++] = array[i ++];
	while(j <= last)
		temp[cur ++] = array[j ++];

	for (int k = 0; k < cur; k ++)
		array[first ++] = temp[k];
}

void MergeSort(LL *array, int first, int last)
{
	if (first == last)
		return ;
	
	int middle = first + (last - first) / 2;
	MergeSort(array, first, middle);
	MergeSort(array, middle+1, last);
	Merge(array, first, middle, last);
}

int main()
{
	int n, i;
	while(scanf("%d", &n), n){
		count = 0;
		for(i = 0; i < n; i ++)
			scanf("%lld", &num[i]);
		MergeSort(num, 0, n - 1);
	/*	for(i = 0; i < n; i ++)
			printf("%lld ", num[i]);
		printf("\n"); */
		printf("%lld\n", count);
	}

	return 0;
}


poj-2299 Ultra—QuickSort(归并排序求逆序数),布布扣,bubuko.com

poj-2299 Ultra—QuickSort(归并排序求逆序数)

标签:逆序数   归并排序   

原文地址:http://blog.csdn.net/tbl_123/article/details/25335741

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!