码迷,mamicode.com
首页 > 其他好文 > 详细

1083. List Grades (25)

时间:2017-03-23 20:20:09      阅读:142      评论:0      收藏:0      [点我收藏+]

标签:color   end   spec   cas   cte   ade   ace   tom   jea   

1083. List Grades (25)

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
... ...
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade‘s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student‘s name and ID, separated by one space. If there is no student‘s grade in that interval, output "NONE" instead.

Sample Input 1:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output 1:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input 2:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output 2:

NONE
#include <iostream>
#include <iomanip>
#include <math.h>
#include <stdio.h>
#include <string>
#include <algorithm>
#include <vector>
#include <map>
#include <stack>
using namespace  std;

struct student
{
    string name;
    string id;
    int score;
}stu[100050];
bool cmp(student a,student b)
{
    return a.score>b.score;
}


int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>stu[i].name>>stu[i].id>>stu[i].score;
    }
    int left,right;
    int cnt_output=0;
    cin>>left>>right;
    vector<int>output;
    sort(stu,stu+n,cmp);
    for(int i=0;i<n;i++)
    {
        if(stu[i].score>=left&&stu[i].score<=right)
        {
            cnt_output++;
            output.push_back(i);
        }
    }
    if(cnt_output==0)
        cout<<"NONE";
    else
    {
       // cout<<cnt_output<<endl;
        for(int i=0;i<cnt_output;i++)
        {
            cout<<stu[output[i]].name<<" "<<stu[output[i]].id<<endl;
        }
    }
    
    
    
    
    return 0;
}

 

1083. List Grades (25)

标签:color   end   spec   cas   cte   ade   ace   tom   jea   

原文地址:http://www.cnblogs.com/brightz2017/p/6606778.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!