码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3535 分组背包

时间:2017-03-24 13:59:28      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:属性   which   str   nts   传递   problem   rip   ace   memory   

题意:

  有n组工作,现在有T分钟时间去做一些工作。每组工作里有m个工作,并且类型为s,s类型可以为0,1,2,分别表示至少选择该组工作的一项,至多选择该工作的一项,不限制选择。每个工作有ci,gi两个属性,表示需要花费ci时间去完成该项工作,完成后将会获得gi的快乐值,现在求快乐值最大多少,如果不能完成工作,输出-1;

原题如下:

AreYouBusy
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4161    Accepted Submission(s): 1655


Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
Whats more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the bosss advice)?

 

Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
 

Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
 

Sample Input
3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1

3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1

1 1
1 0
2 1

5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10
 

Sample Output
5
13
-1
-1
 

代码如下:

#include <iostream>
#include <cstdio>
#include <vector>
#include <cstring>
using namespace std;
#define INF (-99999)
const int Ni = 120;
int dp[Ni][Ni];
int main()
{
    int n,m,i,j,k,num,c,v,typ;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
        {
            scanf("%d%d",&num,&typ);
            if(typ==0) for(int p=0;p<=m;p++) dp[i][p]=INF;

            else //把上一个包的值传递下去,目的是为了给某组可以选择不止一个的时候用
                for(int p=0;p<=m;p++) dp[i][p]=dp[i-1][p];
            for(j=1;j<=num;j++)
            {
                scanf("%d%d",&c,&v);
                for(k=m;k>=c;k--)
                {
                    int a1 = dp[i][k-c]+v;          //在已经选择该组的基础上,再次选择该组里的某个元素。
                    int a2 = dp[i-1][k-c]+v;        //在一个没有选择该组的基础上,选择该组里的元素
                    int a3 = dp[i-1][k];            //不选择该组的元素。
                    if(typ==0)//最少选一个
                        dp[i][k] = max(dp[i][k],max(a1,a2));
                    else if(typ==1)//最多选一个
                        dp[i][k] = max(dp[i][k],max(a2,a3));
                    else //不限
                        dp[i][k] = max(dp[i][k],max(max(a1,a2),a3));
                }
            }
        }
        dp[n][m] = dp[n][m] > 0 ? dp[n][m] : -1;
        printf("%d\n",dp[n][m]);

    }
    return 0;
}

 

hdu 3535 分组背包

标签:属性   which   str   nts   传递   problem   rip   ace   memory   

原文地址:http://www.cnblogs.com/jlyg/p/6610760.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!