码迷,mamicode.com
首页 > 其他好文 > 详细

Bzoj3093 [Fdu校赛2012] A Famous Game

时间:2017-03-25 22:34:13      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:number   read   source   ++   des   stl   概率   with   single   

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 251  Solved: 136

Description

Mr. B and Mr. M like to play with balls. They have many balls colored in blue and red. Firstly, Mr. B randomly picks up N balls out of them and put them into a bag. Mr. M knows that there are N+1 possible situations in which the number of red balls is ranged from 0 to N, and we assume the possibilities of the N+1 situations are the same. But Mr. M does not know which situation occurs. Secondly, Mr. M picks up P balls out of the bag and examines them. There are Q red balls and P-Q blue balls. The question is: if he picks up one more ball out of the bag, what is the possibility that this ball is red?

Input

Each test case contains only one line with three integers N, P and Q (2 <= N <= 100,000, 0 <= P <= N-1, 0 <= Q <= P).

Output

 
For each test case, display a single line containing the case number and the possibility of the next ball Mr. M picks out is red. The number should be rounded to four decimal places.

Sample Input



3 0 0
4 2 1

Sample Output


Case 1: 0.5000
Case 2: 0.5000

HINT

 



[Explanation] 

For example as the sample test one, there are three balls in the bag. The possibilities of the four possible situations are all 0.25. If there are no red balls in the bag, the possibility of the next ball are red is 0. If there is one red ball in the bag, the possibility is 1/3. If there are two red balls, the possibility is 2/3. Finally if all balls are red, the possibility is 1. So the answer is 0*(1/4)+(1/3)*(1/4)+(2/3)*(1/4)+1*(1/4)=0.5.

 

Source

 

数学问题 概率

推出来答案就是(q+1)/(p+2)

可能是近一年写过最短的代码

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
const int mxn=100010;
int read(){
    int x=0,f=1;char ch=getchar();
    while(ch<0 || ch>9){if(ch==-)f=-1;ch=getchar();}
    while(ch>=0 && ch<=9){x=x*10-0+ch;ch=getchar();}
    return x*f;
}
int n,p,q;
int main(){
    int cas=0;
    while(scanf("%d%d%d",&n,&p,&q)!=EOF){
        printf("Case %d: %.4f\n",++cas,(q+1.0)/(p+2.0));
    }
    return 0;
}

 

Bzoj3093 [Fdu校赛2012] A Famous Game

标签:number   read   source   ++   des   stl   概率   with   single   

原文地址:http://www.cnblogs.com/SilverNebula/p/6618698.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!