码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1088 滑雪(经典DP)

时间:2014-08-22 14:33:08      阅读:177      评论:0      收藏:0      [点我收藏+]

标签:poj


滑雪
Time Limit: 1000MS   Memory Limit: 65536K
     

Description

Michael喜欢滑雪百这并不奇怪, 因为滑雪的确很刺激。可是为了获得速度,滑的区域必须向下倾斜,而且当你滑到坡底,你不得不再次走上坡或者等待升降机来载你。Michael想知道载一个区域中最长底滑坡。区域由一个二维数组给出。数组的每个数字代表点的高度。下面是一个例子 
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一个人可以从某个点滑向上下左右相邻四个点之一,当且仅当高度减小。在上面的例子中,一条可滑行的滑坡为24-17-16-1。当然25-24-23-...-3-2-1更长。事实上,这是最长的一条。

Input

输入的第一行表示区域的行数R和列数C(1 <= R,C <= 100)。下面是R行,每行有C个整数,代表高度h,0<=h<=10000。

Output

输出最长区域的长度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

Source


题目大意:
如中文所示。
解题思路:
DP.
代码:
#include<iostream>
#include<cstdio>
#include<cstring>

const int offx[4]={1,0,-1, 0};
const int offy[4]={0,1, 0,-1},maxn=110;
int r,c,dp[maxn][maxn],height[maxn][maxn];

int DP(int x,int y){
    int ret=0;
    if(dp[x][y]!=-1) return dp[x][y];
    for(int i=0;i<4;i++){
        int newx=x+offx[i],newy=y+offy[i];
        if(newx<0||newy<0||newx>=r||newy>=c) continue;
        if(height[x][y]<=height[newx][newy]) continue;
        if(DP(newx,newy)>ret) ret=DP(newx,newy);
    }
    return dp[x][y]=ret+1;
}

void solve(){
    int ans=0;
    for(int i=0;i<r;i++){
        for(int j=0;j<c;j++){
            if(DP(i,j)>ans) ans=DP(i,j);
        }
    }
    printf("%d\n",ans);
}

int main(){
    while(scanf("%d%d",&r,&c)!=EOF){
        memset(dp,-1,sizeof(dp));
        for(int i=0;i<r;i++){
            for(int j=0;j<c;j++){
                scanf("%d",&height[i][j]);
            }
        }
        solve();
    }
    return 0;
}



POJ 1088 滑雪(经典DP)

标签:poj

原文地址:http://blog.csdn.net/hush_lei/article/details/38755639

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!