码迷,mamicode.com
首页 > 其他好文 > 详细

Is the Information Reliable?(差分约束)

时间:2014-08-22 16:18:09      阅读:183      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   os   io   strong   for   ar   

Is the Information Reliable?Crawling in process... Crawling failed Time Limit:3000MS     Memory Limit:131072KB     64bit IO Format:%I64d & %I64u

Description

The galaxy war between the Empire Draco and the Commonwealth of Zibu broke out 3 years ago. Draco established a line of defense called Grot. Grot is a straight line with N defense stations. Because of the cooperation of the stations, Zibu’s Marine Glory cannot march any further but stay outside the line.

A mystery Information Group X benefits form selling information to both sides of the war. Today you the administrator of Zibu’s Intelligence Department got a piece of information about Grot’s defense stations’ arrangement from Information Group X. Your task is to determine whether the information is reliable.

The information consists of M tips. Each tip is either precise or vague.

Precise tip is in the form of P A B X, means defense station A is X light-years north of defense station B.

Vague tip is in the form of V A B, means defense station A is in the north of defense station B, at least 1 light-year, but the precise distance is unknown.

Input

There are several test cases in the input. Each test case starts with two integers N (0 < N ≤ 1000) and M (1 ≤ M ≤ 100000).The next M line each describe a tip, either in precise form or vague form.

Output

Output one line for each test case in the input. Output “Reliable” if It is possible to arrange N defense stations satisfying all the M tips, otherwise output “Unreliable”.

Sample Input

3 4
P 1 2 1
P 2 3 1
V 1 3
P 1 3 1
5 5
V 1 2
V 2 3
V 3 4
V 4 5
V 3 5

Sample Output

Unreliable
Reliable

题意:有N个车站,给出一些点的精确信息和模糊信息,精确信息给出两点的位置和距离,模糊信息给出两点的位置,但距离大于等于一。试确定是否所有的信息满足条件

思路:对于精确信息,可以得出两个差分条件,b-a = c;可以化为b-a >= c && a - b <= -c;(因为是精确信息,故要建立双向边)
对于模糊信息,只能得出一个差分条件,可以化为 b - a <= 1;所以a <= b-1;说明b到a有一条长度为-1的边;(模糊信息,建立单向边)

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
#define inf 9999999999;
struct node
{
    int u,v,w;
} edge[200000];
int dis[200000];
int n,m,cnt;
int Bellman_ford()
{
    int i,j;
    int flag;
    memset(dis,0,sizeof(dis));
    for(i=0;i<n;i++)
    {
        flag = 0;
        for(j=0;j<cnt;j++)
        {
            if(dis[edge[j].v]>dis[edge[j].u]+edge[j].w)
            {
                dis[edge[j].v]=dis[edge[j].u]+edge[j].w;
                flag=1;
            }
        }
        if(!flag)
            break;
    }
    for(j=0;j<cnt;j++)
    {
        if(dis[edge[j].v]>dis[edge[j].u]+edge[j].w)
            return 1;
    }
    return 0;
}

int main()
{
    int i,j;
    int u,v,w;
    char str;
    while(~scanf("%d %d",&n,&m))
    {
        cnt=0;
        for(i=0; i<m; i++)
        {
            getchar();
            scanf("%c",&str);
            if(str=='P')
            {
                scanf("%d %d %d",&u,&v,&w);
                edge[cnt].u=u;
                edge[cnt].v=v;
                edge[cnt].w=w;
                cnt++;
                edge[cnt].u=v;
                edge[cnt].v=u;
                edge[cnt].w=-w;
                cnt++;
            }
            else
            {
                scanf("%d %d",&u,&v);
                edge[cnt].u=v;
                edge[cnt].v=u;
                edge[cnt].w=-1;
                cnt++;
            }
        }
        if(Bellman_ford())
            puts("Unreliable");
        else
            puts("Reliable");
    }
    return 0;
}




Is the Information Reliable?(差分约束)

标签:des   style   http   color   os   io   strong   for   ar   

原文地址:http://blog.csdn.net/u013486414/article/details/38758195

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!