码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1016 dfs+素数表打表

时间:2017-03-30 19:04:20      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:stream   ica   anti   res   i++   turn   lock   rem   ram   

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

技术分享
 

 

Input
n (0 < n < 20).
 

 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

 

Sample Input
6 8
 

 

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 
 
 
题意    环上任意相邻的两个数相加为素数
 
 
代码:

#include<iostream>
#include<string.h>
#include<cstring>
using namespace std;
int n;
#define maxn 10000
int ans[1005] = {0};
bool a[10005]={0};
int su[1500];
int tol = 0;
int vis[1005];
bool ppap(int a)
{
for (int i = 0; i < tol;i++)
if (a%su[i] == 0)return 0;
return 1;
}
void parm()
{
for (int i = 2; i < maxn;i++)
if (ppap(i))
{
su[tol++] = i; a[i] = 1;
}
}
void dfs(int k)
{
if (k == n&&a[ans[0]+ans[k-1]])
{
for (int i = 0; i < n-1; i++)
cout << ans[i] <<" ";
cout <<ans[n-1]<< endl;
return;
}
for (int i = 2; i <=n; i++)
{
if (!vis[i] && a[i + ans[k-1]])
{
ans[k] = i;
vis[i] = 1;
dfs(k + 1);
vis[i] = 0;
}
}
}
int main()
{
int i=1;
while (cin >> n)
{

memset(vis, 0, sizeof(vis));
parm();
ans[0] = 1;
cout<<"Case "<<i<<":"<<endl;
dfs(1);
i++;
}
return 0;

}

hdu 1016 dfs+素数表打表

标签:stream   ica   anti   res   i++   turn   lock   rem   ram   

原文地址:http://www.cnblogs.com/ddddacmer/p/6647412.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!