码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2896 病毒侵袭(AC自动机模版题)

时间:2014-08-22 22:36:57      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   java   os   io   strong   for   ar   

AC自动模版题,中文题目就不叙述题意了啊。

AC自动主要是构造出字典树之后找到fail指针的跳转,类似于KMP里面的next数组的跳转啊,注意这里是多模式跳转。意思就是这个串跳到下一个串的什么位置啊。

先帖一下,做多了再一起总结吧。

病毒侵袭

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11347    Accepted Submission(s): 2934


Problem Description
当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋——我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~
 

Input
第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20—200之间。
每个病毒都有一个编号,依此为1—N。
不同编号的病毒特征码不会相同。
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。
接下来M行,每行表示一个网站源码,源码字符串长度在7000—10000之间。
每个网站都有一个编号,依此为1—M。
以上字符串中字符都是ASCII码可见字符(不包括回车)。
 

Output
依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。
web 网站编号: 病毒编号 病毒编号 …
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。
最后一行输出统计信息,如下格式
total: 带病毒网站数
冒号后有一个空格。
 

Sample Input
3 aaa bbb ccc 2 aaabbbccc bbaacc
 

Sample Output
web 1: 1 2 3 total: 1
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-12
///#define M 1000100
#define LL __int64
///#define LL long long
///#define INF 0x7ffffff
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)

using namespace std;

const int maxn = 1000010;

struct node
{
    int next[130], fail, flag;
} f[maxn];

bool vis[510];

int Top;
char s[1000010];
inline int Sel(char s)
{
    return s-' ';
}
int creat()
{
    memset(f[Top].next, -1, sizeof(f[Top].next));
    f[Top].fail = -1;
    f[Top].flag = 0;
    return Top++;
}

void Get_tree(char *s, int root, int site, int x)
{
    while(s[site] != '\0')
    {
        if(f[root].next[Sel(s[site])] == -1) f[root].next[Sel(s[site])] = creat();
        root = f[root].next[Sel(s[site])];
        site++;
    }
    f[root].flag = x;
}

int Get_fail(int site, int x)
{
    while(1)
    {
        if(site == -1) return 0;
        if(f[site].next[x] != -1) return f[site].next[x];
        site = f[site].fail;
    }
}

queue<int>q;
void Get_fail(int root)
{
    f[root].fail = -1;
    while(!q.empty()) q.pop();
    int x;
    q.push(root);
    while(!q.empty())
    {
        x = q.front();
        q.pop();
        for(int i = 0; i <= 128; i++)
        {
            if(f[x].next[i] != -1)
            {
                f[f[x].next[i]].fail = Get_fail(f[x].fail, i);
                q.push(f[x].next[i]);
            }
        }
    }
}
int Match(char *s, int root, int site)
{
    int p = root;
    int ans = 0;
    int tmp;
    for(site = 1; s[site] != '\0'; site++)
    {
        while(p != -1 && f[p].next[Sel(s[site])] == -1) p = f[p].fail;
        if(p == -1)
        {
            p = root;
            continue;
        }
        p = f[p].next[Sel(s[site])];
        tmp = p;
        while(tmp != root && f[tmp].flag != -1)
        {
            if(f[tmp].flag)
            {
                ans = 1;
                vis[f[tmp].flag] = 1;
            }
            tmp = f[tmp].fail;
        }
    }
    return ans;
}

int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        Top = 0;
        int root = creat();
        for(int i = 1; i <= n; i++)
        {
            scanf("%s", s+1);
            Get_tree(s, root, 1, i);
        }
        Get_fail(root);
        int m;
        scanf("%d",&m);
        int total = 0;
        int ans;
        for(int i = 0; i < m; i++)
        {
            memset(vis, 0, sizeof(vis));
            scanf("%s",s+1);
            ans = Match(s, root, 1);
            if(ans)
            {
                total += ans;
                printf("web %d:", i+1);
                for(int j = 1; j <= n; j++)
                    if(vis[j]) printf(" %d",j);
                puts("");
            }
        }
        printf("total: %d\n",total);
    }
    return 0;
}


HDU 2896 病毒侵袭(AC自动机模版题)

标签:des   style   color   java   os   io   strong   for   ar   

原文地址:http://blog.csdn.net/xu12110501127/article/details/38762237

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!