码迷,mamicode.com
首页 > 其他好文 > 详细

uva 12325 枚举暴力 b

时间:2017-04-01 22:56:44      阅读:375      评论:0      收藏:0      [点我收藏+]

标签:find   swa   with   clu   could   ber   space   multiple   tun   

 

Some brave warriors come to a lost village. They are very lucky and find a lot of treasures and a big treasure chest, but with angry zombies.

The warriors are so brave that they decide to defeat the zombies and then bring all the treasures back. A brutal long-drawn-out battle lasts from morning to night and the warriors find the zombies are undead and invincible.

Of course, the treasures should not be left here. Unfortunately, the warriors cannot carry all the treasures by the treasure chest due to the limitation of the capacity of the chest. Indeed, there are only two types of treasures: emerald and sapphire. All of the emeralds are equal in size and value, and with infinite quantities. So are sapphires.

Being the priest of the warriors with the magic artifact: computer, and given the size of the chest, the value and size of each types of gem, you should compute the maximum value of treasures our warriors could bring back.

Input

There are multiple test cases. The number of test cases T (T技术分享200) is given in the first line of the input file. For each test case, there is only one line containing five integers NS1, V1, S2, V2, denoting the size of the treasure chest is N and the size and value of an emerald isS1 and V1, size and value of a sapphire is S2, V2. All integers are positive and fit in 32-bit signed integers.

Output

For each test case, output a single line containing the case number and the maximum total value of all items that the warriors can carry with the chest.

Sample Input

2 100 1 1 2 2 100 34 34 5 3 

Sample Output

Case #1: 100 Case #2: 86
题目大意:

                     知道背包的容量N,有两件物品占用空间分别为s1和s2,物品价值为v1和v2,,数量有无数个。求背包里能装的物品的最大价值是多少。

解题思路:

           这道题和完全背包的问题类似,但是又有差距,利用完全背包的解法来解明显是行不通的。确定s1和s2 的最小公倍数s,那么在装的时候我们把 N/s 个s都装这种物品,N%s部分枚举。有一点值得注意我们在求N%s部分时,需要拿出一个s和N%s加起来做为枚举的对象(想想就明白)

 

 

#include<iostream>

#include<stdio.h>
using namespace std;
long long  gcd(long long x,long long y)
{
   long long xy=x*y;
   long long   r=x%y;
    while(r)
    {
        x=y;
        y=r;
        r=x%y;
    }
    xy/=y;
    return xy;
}
int main()
{
    long long   n,s1,v1,s2,v2,t,s;
    int T;
    scanf("%d",&T);
    int kase=0;
    while(T--)
    {

        scanf("%lld%lld%lld%lld%lld",&n,&s1,&v1,&s2,&v2);
        s=gcd(s1,s2);
        t=n/s;
        n%=s;
        if(t)
        {
            n+=s;
            t--;
        }

        long long  v = t*max(s/s1*v1,s/s2*v2),vv=0;
        if(s1<s2)
        {swap(s1,s2),swap(v1,v2);}
        for(int i=0;i<=n/s1;i++)
            vv=max((n-i*s1)/s2*v2+i*v1,vv);

        v+=vv;
        printf("Case #%d: %lld\n",++kase,v);
    }
    return 0;
}

uva 12325 枚举暴力 b

标签:find   swa   with   clu   could   ber   space   multiple   tun   

原文地址:http://www.cnblogs.com/552059511wz/p/6657714.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!