码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1312-DFS

时间:2017-04-04 18:43:01      阅读:182      评论:0      收藏:0      [点我收藏+]

标签:print   ogr   int   repr   script   nbsp   getchar   init   ram   

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19690    Accepted Submission(s): 11965


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
 

 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

 

Sample Input
技术分享

 

Sample Output
45
59
6
13
 
 
 
 
好久之前老大讲过的,忘了写了。。。
#include<bits/stdc++.h>
using namespace std;
int direct [4][2]={-1,0,1,0,0,1,0,-1};                                    //方向
char str[25][25];
bool flag[25][25];
int w,h,ans;
void DFS(int x,int y){
    for(int i=0;i<4;i++){
        int p=x+direct[i][0];
        int q=y+direct[i][1];
        if(p>=0&&q>=0&&p<h&&q<w&&flag[p][q]==0&&str[p][q]==.){         //判断,至今仍不明白方向为-1的时候怎么还是>=0,还是我太蠢了。。。
            ans++;
            flag[p][q]=1;
            DFS(p,q);                                                    //递归
        }
    }
}
int main(){
    int i,j,k;
    int Dx,Dy;
    while(~scanf("%d%d",&w,&h)){
        if(w==0&&h==0)break;
        memset(flag,0,sizeof(flag));                                    //这个函数通常为新申请的内存做初始化工作
        getchar();
        for(i=0;i<h;i++){
            for(j=0;j<w;j++){
                scanf("%c",&str[i][j]);
            if(str[i][j]==@){
                Dx=i;
                Dy=j;
            }
            } getchar();
        }
        ans=1;
        flag[Dx][Dy]=1;
        DFS(Dx,Dy);
        printf("%d\n",ans);
    }
    return 0;
}

写下来,等忘的时候再回来看。

啊,我这个菜鸟,好笨。。。┭┮﹏┭┮

HDU1312-DFS

标签:print   ogr   int   repr   script   nbsp   getchar   init   ram   

原文地址:http://www.cnblogs.com/ZERO-/p/6665668.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!