码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3706 Second My Problem First 单调队列

时间:2017-04-04 20:00:52      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:ott   proc   math   map   单调队列   tom   ack   list   arc   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3706

Second My Problem First

Time Limit: 12000/4000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)



Problem Description
Give you three integers n, A and B. 
Then we define Si = Ai mod B and Ti = Min{ Sk | i-A <= k <= i, k >= 1}
Your task is to calculate the product of Ti (1 <= i <= n) mod B.
 

 

Input
Each line will contain three integers n(1 <= n <= 107),A and B(1 <= A, B <= 231-1). 
Process to end of file.
 

 

Output
For each case, output the answer in a single line.
 

 

Sample Input
1 2 3 2 3 4 3 4 5 4 5 6 5 6 7
 

 

Sample Output
2 3 4 5 6
 

 

Author
WhereIsHeroFrom@HDU
 

 

Source
 
单调队列简单题;
卡内存,list过不了,deque,G++过的;
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstring>
#include<vector>
#include<list>
#include<set>
#include<map>
using namespace std;
#define ll long long
#define pi (4*atan(1.0))
#define eps 1e-14
#define bug(x)  cout<<"bug"<<x<<endl;
const int N=1e7+10,M=4e6+10,inf=2147483647;
const ll INF=1e18+10,mod=1e9+7;
///   数组大小
int d[N];
ll num[N];
int main()
{
    ll n,a,b;
    while(~scanf("%lld%lld%lld",&n,&a,&b))
    {
        ll ans=1,base=a%b;
        int s=0,e=0;
        for(int i=1;i<=n;i++,base=(base*a)%b)
        {
            num[i]=base;
            while(s<e&&d[s]<i-a)s++;
            while(e>s&&num[d[e]]>=num[i])e--;
            d[++e]=i;
            //cout<<num[d[s+1]]<<" "<<endl;
            ans=ans*(num[d[s+1]])%b;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

 

 

hdu 3706 Second My Problem First 单调队列

标签:ott   proc   math   map   单调队列   tom   ack   list   arc   

原文地址:http://www.cnblogs.com/jhz033/p/6666204.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!