码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1069 Monkey and Banana LCS变形

时间:2014-08-23 16:55:51      阅读:282      评论:0      收藏:0      [点我收藏+]

标签:acm   dp   lcs   

点击打开链接题目链接

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7617    Accepted Submission(s): 3919


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn‘t be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 


每个长方体都会有三种摆法 

排序后求lcs

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
struct Node
{
    int a,b,c;
}node[105];
int cmp(Node x,Node y)
{
    return x.a<y.a;
}
int dp[105];
int main()
{
    int n,cas=0;
    int i,j;
    int xx[3];
    int ans;
    while(scanf("%d",&n)!=EOF&&n)
    {
        memset(node,0,sizeof(node));
        ans=0;
        for(i=1;i<=n;i++)
        {
            scanf("%d %d %d",&xx[0],&xx[1],&xx[2]);
            sort(xx,xx+3);
            node[i*3-2].a=xx[0],node[i*3-2].b=xx[1],node[i*3-2].c=xx[2];
            node[i*3-1].a=xx[0],node[i*3-1].b=xx[2],node[i*3-1].c=xx[1];
            node[i*3].a=xx[1],node[i*3].b=xx[2],node[i*3].c=xx[0];
        }
        sort(node+1,node+1+n*3,cmp);
        dp[0]=0;
        for(i=1;i<=3*n;i++)
        {
            dp[i]=node[i].c;
        }
        for(i=1;i<=3*n;i++)
        {
            int maxx=0;
            for(j=i-1;j>0;j--)
            {
                if(node[i].a>node[j].a&&node[i].b>node[j].b)
                {
                    maxx=max(maxx,dp[j]);
                }
            }
            dp[i]+=maxx;
            ans=max(ans,dp[i]);
        }
        //for(i=1;i<=3*n;i++)
           // printf("%d ",dp[i]);
        printf("Case %d: maximum height = %d\n",++cas,ans);
    }
    return 0;
}


HDU 1069 Monkey and Banana LCS变形

标签:acm   dp   lcs   

原文地址:http://blog.csdn.net/qq_16843991/article/details/38778419

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!