码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-1018

时间:2017-04-08 15:11:03      阅读:154      评论:0      收藏:0      [点我收藏+]

标签:ber   ring   tput   min   etc   eve   required   smi   tor   

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

 

Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

 

Output

The output contains the number of digits in the factorial of the integers appearing in the input.

 

Sample Input

2

10

20

 

Sample Output

7

19


 

数n的位数计算公式:lg(n)+1 

所以 n!的位数为 lg(n*(n-1)*(n-2)...*3*2*1)+1

        =lg(n)+lg(n-1)+lg(n-2)+...+lg(3)+lg(2)+lg(1)+1

#include <iostream>
#include <cmath>
using namespace std;

int main(void)
{
    double w;
    int t;
    long num;
    
    while(cin >> t)
    {
        while(t--)
        {
            cin >> num;
            
            w = 1;
            for(int i = 1; i <= num; i++)
            {
                w += log10(i);
            }
            cout << (int)w << endl;
        }
    }
    return 0;
}

 

HDU-1018

标签:ber   ring   tput   min   etc   eve   required   smi   tor   

原文地址:http://www.cnblogs.com/limyel/p/6681671.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!