码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1836-Alignment(DP/LIS变形)

时间:2017-04-10 17:38:43      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:series   git   using   lib   desc   family   too   clu   ons   

Alignment
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 13465   Accepted: 4336

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line‘s extremity (left or right). A soldier see an extremity if there isn‘t any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
? 2 <= n <= 1000 
? the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4
最长上升子序列变形。
题意: 一排士兵,要求对于每个士兵。至少保证左边或者右边的人身高单调递增。问满足要求最少要出去多少人。这个问题等价于 最多有多少个士兵能够按要求排成一列。扫两遍LIS ,枚举每个点 求 max(dp_l[i]+dp_r[j]);i:1 to n; j:i+1 to n; 
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <cctype>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
#define ll long long
#define maxn 116
#define pp pair<int,int>
#define INF 0x3f3f3f3f
#define max(x,y) ( ((x) > (y)) ? (x) : (y) )
#define min(x,y) ( ((x) > (y)) ? (y) : (x) )
using namespace std;
int n,dp_l[1010],dp_r[1010];
double a[1010];
void solve()
{
	for(int i=2;i<=n;i++)
		for(int j=1;j<i;j++)
			if(a[i]>a[j]&&dp_l[i]<=dp_l[j])
				dp_l[i]=dp_l[j]+1;
	for(int i=n-1;i>=1;i--)
		for(int j=n;j>i;j--)
			if(a[i]>a[j]&&dp_r[i]<=dp_r[j])
				dp_r[i]=dp_r[j]+1;
	int ans=-INF;
	for(int i=1;i<=n;i++)
		for(int j=i+1;j<=n;j++)
		ans=max(ans,dp_l[i]+dp_r[j]);
	printf("%d\n",n-ans);
}
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++)
		{
			dp_l[i]=1;
			dp_r[i]=1;
			scanf("%lf",&a[i]);
		}
		solve();
	}
	return 0;
}

POJ 1836-Alignment(DP/LIS变形)

标签:series   git   using   lib   desc   family   too   clu   ons   

原文地址:http://www.cnblogs.com/mfmdaoyou/p/6690062.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!