码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-1020 Encoding

时间:2017-04-11 01:26:04      阅读:196      评论:0      收藏:0      [点我收藏+]

标签:where   desc   sample   cte   length   using   win   har   --   

Descripe

Given a string containing only ‘A‘ - ‘Z‘, we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, ‘1‘ should be ignored.

 

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A‘ - ‘Z‘ and the length is less than 10000.

 

Output

For each test case, output the encoded string in a line.

 

Sample Input

2

ABC

ABBCCC

 

Sample Output

ABC

A2B3C


 

#include <iostream>
using namespace std;

int main(void)
{
    char a[10002];
    int t;
    pair<int, char> b[1000];
    
    while(cin >> t)
    {
        while(t--)
        {
            int i = 0;
            int n = 0;
            
            cin >> a;
            if(strlen(a)==1)
            {
                cout << a << endl;
                continue;
            }
            for( ; a[i]!=‘\0‘; i++)
            {
                if(i==0 || a[i]!=a[i-1])
                {
                    b[n].first = 0;
                    b[n].second = a[i];
                }
                if(a[i]!=a[i+1])
                {
                    b[n++].first++;
                    continue;
                }
                b[n].first++;
            }
            for(i = 0; i < n; i++)
            {
                if(b[i].first!=1)
                    cout << b[i].first;
                cout << b[i].second;
            }
            cout << endl;
        }
    }
    return 0;
}

 

HDU-1020 Encoding

标签:where   desc   sample   cte   length   using   win   har   --   

原文地址:http://www.cnblogs.com/limyel/p/6691466.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!