码迷,mamicode.com
首页 > 其他好文 > 详细

codevs 1792 分解质因数

时间:2017-04-14 22:31:11      阅读:222      评论:0      收藏:0      [点我收藏+]

标签:add   desc   部分   cti   color   problem   cstring   one   ==   

1792 分解质因数

 
题目描述 Description

编写一个把整数N分解为质因数乘积的程序。

输入描述 Input Description

输入一个整数 N

输出描述 Output Description

输出 分解质因数 。拆成几个质数相乘的形式,质数必须从小到大相乘

样例输入 Sample Input

756

样例输出 Sample Output

756=2*2*3*3*3*7

#include<cstdio>
#include<cmath>
#include<string>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;

int tot;
int i,m=2;
int a,b;

int main()
{
    int n;
    scanf("%d",&n);
    i=n;
    a=i;
    printf("%d=",i);
    while(i!=1)
    {
        if(i%m!=0)
            m++;
        else
        {
            if(a==i)
                printf("%d",m);
            else    printf("*%d",m); 
            i/=m;
        }
    }//巧妙的部分o(∩_∩)o
  //printf("\b");

   return 0;
}

自我感觉思路巧妙o(∩_∩)o


codevs 1792 分解质因数

标签:add   desc   部分   cti   color   problem   cstring   one   ==   

原文地址:http://www.cnblogs.com/kuaileyongheng/p/6710976.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!