码迷,mamicode.com
首页 > 其他好文 > 详细

poj3278Catch That Cow

时间:2017-04-14 23:56:45      阅读:304      评论:0      收藏:0      [点我收藏+]

标签:new   immediate   font   medium   tin   space   app   any   problem   

Catch That Cow
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 88361   Accepted: 27679

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>

using namespace std;

int que[200001];
int start=0,endd=0;
int time[200001]={0};
int vis[200001]={0};
int n,k;

int bfs(int n,int k){
    memset(que,0,sizeof(que));
    memset(time,0,sizeof(time));
    memset(vis,0,sizeof(vis));
    start=0;
    endd=0;
    que[endd++]=n;
    vis[n]=1;
    while(start<endd){
        int t=que[start];
        start++;
        for(int i=0;i<3;i++){
            int tt=t;
            if(i==0){
                tt+=1;
            }else if(i==1){
                tt-=1;
            }else if(i==2){
                tt*=2;
            }
            if(tt>100000||tt<0){
                continue;
            }
            if(!vis[tt]){
                vis[tt]=1;
                que[endd]=tt;
                time[tt]=time[t]+1;
                if(tt==k){
                    return time[tt];
                }
                endd++;
            }
        }
    }
}

int main()
{
    int ans;
    while(~scanf("%d %d",&n,&k)){
        if(n<k){
            ans=bfs(n,k);
        }else{
            ans=n-k;
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

poj3278Catch That Cow

标签:new   immediate   font   medium   tin   space   app   any   problem   

原文地址:http://www.cnblogs.com/TWS-YIFEI/p/6711393.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!