码迷,mamicode.com
首页 > 其他好文 > 详细

Problem A: 类的初体验

时间:2017-04-15 00:07:20      阅读:143      评论:0      收藏:0      [点我收藏+]

标签:using   php   tail   key   lang   number   cin   类型   pac   

Description

定义一个类Data,只有一个double类型的属性和如下3个方法:
1.    void init(double d);——初始化属性值。

2.   double getValue()——获得属性值。

3.    void showValue()——显示属性值。

Input

一个double类型的数值。

Output

输出输入的值2次,每次占一行。

Sample Input

3.14

Sample Output

3.14 3.14

HINT

Append Code

int main()
{
    Data data;
    double d;
    cin>>d;
    data.init(d);
    cout<<data.getValue()<<endl;
    data.showValue();
}
 
代码
 
#include <iostream>
#include <iomanip>
using namespace std;

class Data
{
    private:
    double a;
    public:
        void init(double d)
        {
            a=d;
        }
        double getValue()
        {
            return a;
        }
        void showValue()
        {
            cout<<a<<endl;
        }
};
int main()
{
    Data data;
    double d;
    cin>>d;
    data.init(d);
    cout<<data.getValue()<<endl;
    data.showValue();
}

Problem A: 类的初体验

标签:using   php   tail   key   lang   number   cin   类型   pac   

原文地址:http://www.cnblogs.com/go-ahead-TT/p/6711330.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!