码迷,mamicode.com
首页 > 其他好文 > 详细

[USACO07DEC]手链Charm Bracelet——01背包

时间:2017-04-16 17:03:08      阅读:137      评论:0      收藏:0      [点我收藏+]

标签:scan   eve   div   for   line   more   describes   abi   n+1   

题目描述

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

有N件物品和一个容量为V的背包。第i件物品的重量是c[i],价值是w[i]。求解将哪些物品装入背包可使这些物品的重量总和不超过背包容量,且价值总和最大。

输入输出格式

输入格式:

 

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

 

输出格式:

 

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

 

输入输出样例

输入样例#1:
4 6
1 4
2 6
3 12
2 7
输出样例#1:
23


代码
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int n,v,c[3403],d[3403],f[1000000];
int main()
{
    scanf("%d%d",&n,&v);
    for(int i=1;i<=n;i++)
    {
        scanf("%d%d",&d[i],&c[i]);
    }
    for(int i=1;i<=n;i++)
      for(int m=v;m>=d[i];m--)
        f[m]=max(f[m],f[m-d[i]]+c[i]);
    printf("%d",f[v]);
    return 0;
}

 

 

[USACO07DEC]手链Charm Bracelet——01背包

标签:scan   eve   div   for   line   more   describes   abi   n+1   

原文地址:http://www.cnblogs.com/z360/p/6719136.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!