码迷,mamicode.com
首页 > 其他好文 > 详细

栈(括号匹配)

时间:2017-04-17 14:23:29      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:ace   pac   ext   har   inpu   clu   sample   strlen   namespace   

假设一个算术表达式中可以包含三种括号:圆括号“(”和“)”,方括号“[”和“]”和花括号“{”和“ ”,且这三种括号可按任意的次序嵌套使用(如:…[…{… …[…]…]…[…]…(…)…)。编写判别给定表达式中所含括号是否正确配对出现的算法。输出结果YES 或者 NO。

Input

5+{[2X5]+2}

Output

YES

Sample Input

8-[{2+7]}

Sample Output

NO

#include<iostream>
#include<stack>
#include<cstring>
#include<cstdio>
using namespace std;
int main()
{
    stack<char> s;
    char a[10000]={0},t;
    int l;
    gets(a);
    l=strlen(a);
    for(int i=0;i<=l-1;++i)
    {
        if(a[i]==(||a[i]==[||a[i]==})
        {
            s.push(a[i]);
        }
        if(a[i]==))
        {
           t=s.top();
           if(t==()
               s.pop();
           else
           {
               cout<<"NO"<<endl;
               return 0;
           }
        }
        if(a[i]==])
        {
           t=s.top();
           if(t==[)
               s.pop();
           else
           {
               cout<<"NO"<<endl;
               return 0;
           }
        }
        if(a[i]==})
        {
           t=s.top();
           if(t=={)
               s.pop();
           else
           {
               cout<<"NO"<<endl;
               return 0;
           }
        }
    }
        cout<<"YES"<<endl;
    return 0;
}

 

栈(括号匹配)

标签:ace   pac   ext   har   inpu   clu   sample   strlen   namespace   

原文地址:http://www.cnblogs.com/ljhacm/p/6722447.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!