码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3258-River Hopscotch-二分

时间:2017-04-17 22:11:57      阅读:242      评论:0      收藏:0      [点我收藏+]

标签:std   sam   英语   cal   amp   end   its   sum   else   

二分,O(≧口≦)O,要哭了。。。一开始怎么都没搞懂题意,果然要好好学英语了。。。/(ㄒoㄒ)/~~

这个题要好好看题意,不翻译了,再翻译错就丢人了。。。

这个题就是排排坐,二分就可以了。。。

                                                                           River Hopscotch

Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 13253   Accepted: 5652

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to M rocks (0 ≤ MN).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: L, N, and M
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).
代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
int main(){
    int a[50050];
    int l,n,m,i;
    int maxx,minn,mid,cnt,sum;
    while(~scanf("%d%d%d",&l,&n,&m)){
            a[0]=0;a[n+1]=l;
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
            sort(a,a+n+1);
            maxx=l;
            minn=100000000000;
        for(i=1;i<=n+1;i++)
            minn=min(minn,a[i]-a[i-1]);
        while(minn<=maxx){
            mid=(minn+maxx)>>1;
            cnt=sum=0;
            for(i=1;i<=n+1;i++){
                if((sum+=a[i]-a[i-1])<=mid)
                    cnt++;
                else
                    sum=0;
            }
            if(cnt<=m)
                minn=mid+1;
            else
                maxx=mid-1;
        }
        printf("%d\n",minn);
    }
    return 0;
}
//总算知道自己哪里错了。。。n应该+1的。智障哟。。。

没什么想写的了。。。(╯°Д°)╯︵┻━┻

(逃。。。

POJ3258-River Hopscotch-二分

标签:std   sam   英语   cal   amp   end   its   sum   else   

原文地址:http://www.cnblogs.com/ZERO-/p/6724883.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!