码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3067 Japan (树状数组)

时间:2014-08-24 23:54:53      阅读:263      评论:0      收藏:0      [点我收藏+]

标签:des   style   os   io   for   ar   art   问题   div   

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5



这题每个点可以发出多条边,只需按照每条边的端点大小排序,先按照左边从大到小,然后右边从大到小。 这样处理之后,左边的端点依次标记为1 ~ num。不会对结果造成影响。然后就是赤裸裸的逆序对的问题了。


#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <set>
#include <stack>
#include <cctype>
#include <algorithm>
#define lson o<<1, l, m
#define rson o<<1|1, m+1, r
using namespace std;
typedef long long LL;
const int mod = 99999997;
const int MAX = 1000000000;
const int maxn = 100005;
int t, n, m, k, f[1000005];
struct C {
    int st, en;
} in[1000005];
LL c[1000005];
bool cmp(C x, C y) {
    if(x.st != y.st) return x.st < y.st;
    return x.en < y.en;
}
int main()
{
   // freopen("in.txt", "r", stdin);
    cin >> t;
    for(int ca = 1; ca <= t; ca++) {
        cin >> n >> m >> k;
        for(int i = 0; i < k; i++) scanf("%d%d", &in[i].st, &in[i].en);
        sort(in, in+k, cmp);
        int num = 0;
        for(int i = 0; i < k; i++) {
            num++;
            in[i].st = num;
            f[num] = in[i].en;
        }
        memset(c, 0, sizeof(c));
        LL sum = 0;
        for(int i = 1; i <= num; i++) {
            for(int j = f[i]+1; j <= maxn; j += j&-j) sum += c[j];
            for(int j = f[i]; j > 0; j -= j&-j) c[j]++;
        }
        printf("Test case %d: %I64d\n", ca, sum);
    }

    return 0;
}



POJ 3067 Japan (树状数组)

标签:des   style   os   io   for   ar   art   问题   div   

原文地址:http://blog.csdn.net/u013923947/article/details/38803925

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!