码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 2001 计算两点间的距离

时间:2017-04-22 17:30:35      阅读:234      评论:0      收藏:0      [点我收藏+]

标签:mil   man   ota   new   tle   top   des   ted   int   


计算两点间的距离

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 94608    Accepted Submission(s): 36310


Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
 

Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
 

Output
对于每组输入数据,输出一行,结果保留两位小数。

 

Sample Input
0 0 0 1 0 1 1 0
 

Sample Output
1.00 1.41
 
 


 

#include<stdio.h>
#include<math.h>
int main()
{
   float x1,y1,x2,y2,result;
   while(scanf("%f%f%f%f",&x1,&y1,&x2,&y2)!=EOF)
   {
   result=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
   printf("%.2f\n",result);
   }
   return 0;
}


 

HDOJ 2001 计算两点间的距离

标签:mil   man   ota   new   tle   top   des   ted   int   

原文地址:http://www.cnblogs.com/slgkaifa/p/6748176.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!