码迷,mamicode.com
首页 > 其他好文 > 详细

Codeforces Round #169 (Div. 2)C. Little Girl and Maximum Sum

时间:2017-04-22 20:43:41      阅读:349      评论:0      收藏:0      [点我收藏+]

标签:memset   clu   mem   include   imu   and   __int64   pen   使用   

传送门

Description

The little girl loves the problems on array queries very much.

One day she came across a rather well-known problem: you‘ve got an array of n elements (the elements of the array are indexed starting from 1); also, there are q queries, each one is defined by a pair of integers liri (1 ≤ li ≤ ri ≤ n). You need to find for each query the sum of elements of the array with indexes from li to ri, inclusive.

The little girl found the problem rather boring. She decided to reorder the array elements before replying to the queries in a way that makes the sum of query replies maximum possible. Your task is to find the value of this maximum sum.

Input

The first line contains two space-separated integers n (1 ≤ n ≤ 2·105) and q (1 ≤ q ≤ 2·105) — the number of elements in the array and the number of queries, correspondingly.

The next line contains n space-separated integers ai (1 ≤ ai ≤ 2·105) — the array elements.

Each of the following q lines contains two space-separated integers li and ri (1 ≤ li ≤ ri ≤ n) — the i-th query.

Output

In a single line print a single integer — the maximum sum of query replies after the array elements are reordered.

Please, do not use the %lld specifier to read or write 64-bit integers in С++. It is preferred to use the cin, cout streams or the %I64dspecifier.

Sample Input

3 3
5 3 2
1 2
2 3
1 3
5 3
5 2 4 1 3
1 5
2 3
2 3

Sample Output

25

33

思路

题意:

给出n个数和q个区间查询,问如何排列这n个数,使得区间查询的数的总和最大。

题解:

统计每个数出现的次数,则总和最大的策略为:依次让最大的数放在出现查询区间最多的位置上。重点在于如何快速的统计每个区间总共被查询的次数。可使用线段树的区间更新,也可使用巧妙一点的方法,通过一个数组记录下每次查询的 L  R,然后 cnt[L]++,cnt[R+1]--,然后统计cnt数组前缀和,因为是cnt[R+1]--,所以从头开始遍历计算前缀和不会多统计那些没有查询的区间的次数。

 

#include<bits/stdc++.h>
using namespace std;
typedef __int64 LL;
const int maxn = 200005;
int a[maxn],cnt[maxn];

bool cmp(int x,int y)
{
	return x >= y;
}

int main()
{
	//freopen("input.txt","r",stdin);
	int n,q,l,r;
	LL res = 0;
	memset(cnt,0,sizeof(cnt));
	scanf("%d%d",&n,&q);
	for (int i = 1;i <= n;i++)	scanf("%d",&a[i]);
	while (q--)
	{
		scanf("%d%d",&l,&r);
		cnt[l]++;
		cnt[r+1]--;
	}
	for (int i = 1;i <= n;i++)	cnt[i] += cnt[i-1];
	sort(a+1,a+n+1);
	sort(cnt+1,cnt+n+1);
	for (int i = n;i > 0;i--)
	{
		res += LL(a[i])*(LL)cnt[i];
	}
	printf("%I64d\n",res);
	return 0;
}

  

Codeforces Round #169 (Div. 2)C. Little Girl and Maximum Sum

标签:memset   clu   mem   include   imu   and   __int64   pen   使用   

原文地址:http://www.cnblogs.com/zzy19961112/p/6749017.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!