码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4287 Intelligent IME(map运用)

时间:2017-04-24 10:04:12      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:map   letters   log   article   tab   recommend   rip   ace   key   

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4287


Intelligent IME

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2091    Accepted Submission(s): 1031


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?


 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
1 3 5 46 64448 74 go in night might gn
 

Sample Output
3 2 0
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  4267 4276 4268 4269 4270 
 


题目大意:手机键盘中与数字2相相应的字母有a,b,c;3相相应的字母有d,e,f。

给出一些数字串如34,和一些小写字母串。求小写字母相应的数字串出现的次数。

字符串abc相应的数字串是111。dh相应的数字串是34。则小写字符串中111出现一次,34出现一次。


代码例如以下:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdlib>
#include <climits>
#include <ctype.h>
#include <queue>
#include <stack>
#include <vector>
#include <deque>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
#define INF 0xffffff
map<int,int>mm;
int cnt[999999];
int main()
{
    
    mm[‘a‘]=mm[‘b‘]=mm[‘c‘]=2;
    mm[‘d‘]=mm[‘e‘]=mm[‘f‘]=3;
    mm[‘g‘]=mm[‘h‘]=mm[‘i‘]=4;
    mm[‘j‘]=mm[‘k‘]=mm[‘l‘]=5;
    mm[‘m‘]=mm[‘n‘]=mm[‘o‘]=6;
    mm[‘p‘]=mm[‘q‘]=mm[‘r‘]=mm[‘s‘]=7;
    mm[‘t‘]=mm[‘u‘]=mm[‘v‘]=8;
    mm[‘w‘]=mm[‘x‘]=mm[‘y‘]=mm[‘z‘]=9;
    int t,N,M,sum;
    int i,j,k;
    int a[5047],b[5047];
    char s[47];
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            scanf("%d%d",&N,&M);
            memset(cnt,0,sizeof(cnt));
            for(i = 0 ; i < N ; i++ )
            {
                scanf("%d",&a[i]);
            //    printf("%d\n",a[i]);
            }
            for(i = 0 ; i < M ;i++)
            {
                scanf("%s",s);
                int len = strlen(s);
                sum = 0;
                for(j = 0 ; j < len ; j++)
                {
                    sum = sum*10+mm[s[j]];
                }
                cnt[sum]++;
            }
            int k = 0;
            for(i = 0 ; i < N ; i++)
            {
                printf("%d\n",cnt[a[i]]);
            }

        }
    }
    return 0;
    
}


HDU 4287 Intelligent IME(map运用)

标签:map   letters   log   article   tab   recommend   rip   ace   key   

原文地址:http://www.cnblogs.com/gavanwanggw/p/6755034.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!