码迷,mamicode.com
首页 > 其他好文 > 详细

[ACM] poj 2017 Speed Limit

时间:2017-04-24 10:07:12      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:stdio.h   target   padding   idt   clu   previous   mit   turn   ota   

Speed Limit
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 17030   Accepted: 11950

Description

Bill and Ted are taking a road trip. But the odometer in their car is broken, so they don‘t know how many miles they have driven. Fortunately, Bill has a working stopwatch, so they can record their speed and the total time they have driven. Unfortunately, their record keeping strategy is a little odd, so they need help computing the total distance driven. You are to write a program to do this computation.

For example, if their log shows
Speed in miles perhour Total elapsed time in hours
20 2
30 6
10 7

this means they drove 2 hours at 20 miles per hour, then 6-2=4 hours at 30 miles per hour, then 7-6=1 hour at 10 miles per hour. The distance driven is then (2)(20) + (4)(30) + (1)(10) = 40 + 120 + 10 = 170 miles. Note that the total elapsed time is always since the beginning of the trip, not since the previous entry in their log.

Input

The input consists of one or more data sets. Each set starts with a line containing an integer n, 1 <= n <= 10, followed by n pairs of values, one pair per line. The first value in a pair, s, is the speed in miles per hour and the second value, t, is the total elapsed time. Both s and t are integers, 1 <= s <= 90 and 1 <= t <= 12. The values for t are always in strictly increasing order. A value of -1 for n signals the end of the input.

Output

For each input set, print the distance driven, followed by a space, followed by the word "miles"

Sample Input

3
20 2
30 6
10 7
2
60 1
30 5
4
15 1
25 2
30 3
10 5
-1

Sample Output

170 miles
180 miles
90 miles

Source

解题思路:

一段时间的速度*这一段时间=这一段时间走得距离,几段时间距离和累加就能够了。

代码:

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <queue>
#include <stack>
#include <iomanip>
#include <cmath>
using namespace std;

int n;
int s[12],t[12];

int main()
{
    while(cin>>n&&n!=-1)
    {
        t[0]=0;
        for(int i=1;i<=n;i++)
            cin>>s[i]>>t[i];
        int total=0;
        for(int i=1;i<=n;i++)
            total+=(t[i]-t[i-1])*s[i];
        cout<<total<<" miles"<<endl;
    }
    return 0;
}


 

[ACM] poj 2017 Speed Limit

标签:stdio.h   target   padding   idt   clu   previous   mit   turn   ota   

原文地址:http://www.cnblogs.com/lxjshuju/p/6755183.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!