标签:which 水题 return with world input dea ++ efi
Description
Input
Output
Sample Input
10 9 1 2 1 3 1 4 1 5 1 6 1 7 1 8 1 9 1 10 10 4 2 3 4 5 4 8 5 8 0 0
Sample Output
Case 1: 1 Case 2: 7
题意:学校有n个同学,每个同学有且只有一个信仰,给出m对有同一信仰的同学,问存在多少种不同的信仰?
输入0 0时结束程序。
思路:初始有n位同学,有n个集合,有n个信仰,对于给出的m对同学:若原来不知他们有同一信仰,则合并他们各自所在集合`信仰数减一。
#include <cstdio>
using namespace std;
#define max_n 50050
int n,m;
int par[max_n];
void init(int n)
{
for(int i=1;i<=n;i++)
{
par[i]=i;
}
}
int find(int x)
{
if(par[x]==x)
return x;
else
{
return par[x]=find(par[x]);
}
}
bool same(int x,int y)
{
return find(x)==find(y);
}
void unit(int x,int y)
{
int fx=find(x);
int fy=find(y);
par[fx]=fy;
}
int main()
{
int d=1;
while(scanf("%d%d",&n,&m))
{
if(n==0&&m==0)
break;
init(n);
int ans=n;
for(int i=1;i<=m;i++)
{
int x,y;
scanf("%d%d",&x,&y);
if(!same(x,y))
{
ans--;
unit(x,y);
}
}
printf("Case %d: %d\n",d,ans);
d++;
}
return 0;
}
标签:which 水题 return with world input dea ++ efi
原文地址:http://www.cnblogs.com/onlyli/p/6761275.html