码迷,mamicode.com
首页 > 其他好文 > 详细

ACboy needs your help-分组背包模板题

时间:2017-04-27 19:30:04      阅读:267      评论:0      收藏:0      [点我收藏+]

标签:int   help   type   --   action   print   text   jid   turn   

Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u

 Status

Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit? 
 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. 
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. 
N = 0 and M = 0 ends the input. 
 

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain. 
 

Sample Input

2 2 1 2 1 3 2 2 2 1 2 1 2 3 3 2 1 3 2 1 0 0
 

Sample Output

3 4 6
 
/*
Author: 2486
Memory: 1456 KB		Time: 93 MS
Language: G++		Result: Accepted
*/
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
typedef long long LL;
const int maxn=100+5;
int dp[maxn],a[maxn][maxn];
int n,m;
int main() {
    while(~scanf("%d%d",&n,&m),n&&m) {
        for(int i=1; i<=n; i++) {
            for(int j=1; j<=m; j++) {
                scanf("%d",&a[i][j]);
            }
        }
        memset(dp,0,sizeof(dp));
        int Max=0;
        for(int i=1; i<=n; i++) {
            for(int k=m; k>=0; k--) {
                for(int j=1; j<=m; j++) {
                    if(k-j<0)break;
                    dp[k]=max(dp[k],dp[k-j]+a[i][j]);
                }
            }
        }
        printf("%d\n",dp[m]);
    }
    return 0;
}

ACboy needs your help-分组背包模板题

标签:int   help   type   --   action   print   text   jid   turn   

原文地址:http://www.cnblogs.com/zhchoutai/p/6775446.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!