码迷,mamicode.com
首页 > 其他好文 > 详细

Poj1837 Balance 动态规划-01背包

时间:2017-04-30 01:02:20      阅读:233      评论:0      收藏:0      [点我收藏+]

标签:space   which   finally   状态   can   value   arm   ted   i++   

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm‘s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
? the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
? the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-‘ for the left arm and ‘+‘ for the right arm);
? on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights‘ values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

思路:

第一次做背包的题,感觉不是很好想...此类问题的关键在于找到状态转移方程

F[i][j]用来表示将前i个物品放上钩,使力矩为j的情况数

状态转移方程:F[i][j]=F[i][j]+F[i][j-temp]  (if F[i][j-temp]>=1)

其中,temp枚举第i个物品的每一个力矩。

 

代码:

#include<iostream>
using namespace std;
int n[100], m[100];
int F[20][100000];
int main()
{
    int C, G;
    scanf("%d%d", &C, &G);
    for (int i = 0; i < C; i++)scanf("%d", &n[i]);
    for (int i = 0; i < G; i++)scanf("%d", &m[i]);
    for (int i = 0; i < C; i++) { 
        int temp = n[i] * m[0]; 
        F[0][temp + 8000] = F[0][temp + 8000]+1;
    }
    for (int i = 1; i < G; i++)
    {
        for (int j = 0; j < C; j++)
        {
            int temp = n[j] * m[i];
            for (int k = 0; k < 100000; k++)
            {
                if (F[i - 1][k]>=1) F[i][k + temp] = F[i][k+temp]+F[i-1][k];
            }
        }
    }
    printf("%d", F[G - 1][8000]);
}

 

Poj1837 Balance 动态规划-01背包

标签:space   which   finally   状态   can   value   arm   ted   i++   

原文地址:http://www.cnblogs.com/zhy-ang/p/6786614.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!