码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1163&& 3176 The Triangle(DP)

时间:2017-04-30 17:12:13      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:大数   题意   miss   plm   roman   i++   main   art   show   

The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 41169   Accepted: 24882

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source




    题意:求走过这个三角形时的最大数值。起点为第一行的唯一的那一个数,终点是第n行的某一个数。当中要走dp[i][j]的话。他的上一步仅仅能是dp[i-1][j-1]或者dp[i-1][j];



#include<iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>

#define inf 9999
#define INF -9999

using namespace std;

int n;
int dp[361][361];

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=i;j++)
            {
                scanf("%d",&dp[i][j]);
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=i;j++)
            {
                dp[i][j] += max(dp[i-1][j-1],dp[i-1][j]);
            }
        }
        int maxx = 0;
        for(int i=1;i<=n;i++)
        {
            if(maxx<dp[n][i])
            {
                maxx = dp[n][i];
            }
        }
        printf("%d\n",maxx);
    }
    return 0;
}


POJ 1163&amp;&amp; 3176 The Triangle(DP)

标签:大数   题意   miss   plm   roman   i++   main   art   show   

原文地址:http://www.cnblogs.com/yxysuanfa/p/6789739.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!