码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1039 Easier Done Than Said?

时间:2014-08-25 22:58:55      阅读:311      评论:0      收藏:0      [点我收藏+]

标签:hdu1039

Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7822    Accepted Submission(s): 3863


Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it‘s your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee‘ or ‘oo‘.

(For the purposes of this problem, the vowels are ‘a‘, ‘e‘, ‘i‘, ‘o‘, and ‘u‘; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
 

Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word ‘end‘ that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.
 

Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.
 

Sample Input
a tv ptoui bontres zoggax wiinq eep houctuh end
 

Sample Output
<a> is acceptable. <tv> is not acceptable. <ptoui> is not acceptable. <bontres> is not acceptable. <zoggax> is not acceptable. <wiinq> is not acceptable. <eep> is acceptable. <houctuh> is acceptable.
 

Source

用java写得很不熟练,缝缝补补地才勉强通过。很多地方没有C自由。

import java.util.Scanner;

public class Main{
	public static void main(String[] args){
		Scanner cin = new Scanner(System.in);
		final String str1 = " is acceptable.", str2 = " is not acceptable.";
		String str;
		while(true){
			str = cin.next();
			if(str.equals("end")) break;
			System.out.print('<' + str +'>');
			if(check(str)) System.out.println(str1);
			else System.out.println(str2);
		}
	}

	public static boolean check(String str){
		int a = 0, b = 0, c = 0;
		boolean ok = false; char ch;
		for(int i = 0; i < str.length(); ++i){
			ch = str.charAt(i);
			if(isVowel(ch)){
				ok = true; b = 0;
				if(++a == 3) return false;
			}else{
				a = 0;
				if(++b == 3) return false;
			}
			if(i != 0 && ch == str.charAt(i-1) && ch != 'e' && ch != 'o')
				return false;
		}
		return ok;
	}

	public static boolean isVowel(char ch){
		if(ch == 'a' || ch == 'e' || ch == 'i'
			 || ch == 'o'|| ch == 'u') return true;
		return false;
	}
}


HDU1039 Easier Done Than Said?

标签:hdu1039

原文地址:http://blog.csdn.net/chang_mu/article/details/38826873

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!