码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2533 Longest Ordered Subsequence DP

时间:2017-05-06 13:22:15      阅读:135      评论:0      收藏:0      [点我收藏+]

标签:body   ram   contain   eof   line   man   iss   ogr   cstring   

Longest Ordered Subsequence
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 32192   Accepted: 14093

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4



#include<iostream>
#include<cstring>
using namespace std;


int main()
{
	int n;
	while(cin>>n)
	{
		int a[1005],b[1005];
		memset(b,0,sizeof(b));
		int i,j;
		for(i=0;i<n;i++)
			cin>>a[i];
		for(i=0;i<n;i++)
		{
			b[i]=1;
			for(j=0;j<i;j++)
				if(a[j]<a[i]&&b[i]<b[j]+1)
					b[i]++;
		}
		int max=0;
		for(i=0;i<n;i++)
			if(max<b[i])    max=b[i];
		cout<<max<<endl;
	}
	return 0;
}


POJ 2533 Longest Ordered Subsequence DP

标签:body   ram   contain   eof   line   man   iss   ogr   cstring   

原文地址:http://www.cnblogs.com/zhchoutai/p/6816135.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!