码迷,mamicode.com
首页 > 其他好文 > 详细

1005 Number Sequence

时间:2017-05-06 23:09:08      阅读:367      评论:0      收藏:0      [点我收藏+]

标签:数字   bottom   des   value   esc   ane   and   space   std   

Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3 1 2 10 0 0 0
 

 

Sample Output
2 5
 

#include<iostream>
using namespace std;
#define N 10000
int main()
{
int A,B,n;
cin>>A>>B>>n;
n=n%49;
while(!(A==0&&B==0&&n==0))
{
long long int a[N];
a[1]=1;
a[2]=1;
if(n==1||n==2)
{
cout<<1<<endl;
}
else
{
for(int i=3;i<=n;i++)
{
a[i]=(A*a[i-1]+B*a[i-2])%7;
}
cout<<a[n]<<endl;
}
cin>>A>>B>>n;
n=n%49;
}
return 0;
}

 

由于f(n)是由前两个数字组合产生,那么只要有两个数字组合相同的情况发生就一定一会产生循环!
两个数字的组合的最大可能值为7x7=49,因此只要在调用迭代方法中限制n的在0~48就可以了

1005 Number Sequence

标签:数字   bottom   des   value   esc   ane   and   space   std   

原文地址:http://www.cnblogs.com/97-ly/p/6818669.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!