标签:包含 get 实例 etc amp print 多行 inpu while
/*字符串统计
Problem Description
对于给定的一个字符串,统计当中数字字符出现的次数。
Input
输入数据有多行。第一行是一个整数n,表示測试实例的个数。后面跟着n行。每行包含一个由字母和数字组成的字符串。
Output
对于每一个測试实例。输出该串中数值的个数。每一个输出占一行。
Sample Input
2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf
Sample Output
6
9
*/
#include<cstdio>
int main()
{
int test;
char str;
scanf("%d",&test);
getchar();
while(test--)
{
int t=0;
while(scanf("%c",&str),str!=‘\n‘)
if(str>=‘0‘&&str<=‘9‘)
{
t++;
}
printf("%d\n",t);
}
return 0;
}
标签:包含 get 实例 etc amp print 多行 inpu while
原文地址:http://www.cnblogs.com/jzssuanfa/p/6819700.html