码迷,mamicode.com
首页 > 其他好文 > 详细

1008 FatMouse' Trade

时间:2017-05-07 11:49:08      阅读:202      评论:0      收藏:0      [点我收藏+]

标签:==   put   each   require   oom   rip   inpu   ane   lin   

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

 

Sample Output
13.333 31.500
 

#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
int m,n,x,y;
double z;
cin>>m>>n;
while(m!=-1&&n!=-1)
{
double s=0;
int F[1000],J[10000];
double Q[10000];
for(int i=0;i<n;i++)
{
cin>>J[i]>>F[i];
if(J[i]==0&&F[i]==0)
Q[i]=0;
else if(J[i]==0)
Q[i]=0;
else if(F[i]==0)
Q[i]=1000000000;
else
Q[i]=J[i]/(double)F[i];
}
for(int i=0;i<n-1;i++)
for(int j=i+1;j<n;j++)
{
if(Q[i]<Q[j])
{
z=Q[i];
Q[i]=Q[j];
Q[j]=z;
x=F[i];
F[i]=F[j];
F[j]=x;
y=J[i];
J[i]=J[j];
J[j]=y;
}
}
for(int i=0;i<n&&m!=0;i++)
{
if(m>F[i])
{
s+=J[i];
m=m-F[i];
}
else
{
s+=m*Q[i];
m=0;
}
}
printf("%.3f\n",s);
cin>>m>>n;
}
return 0;
}

 

1008 FatMouse' Trade

标签:==   put   each   require   oom   rip   inpu   ane   lin   

原文地址:http://www.cnblogs.com/97-ly/p/6819531.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!