码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1523 SPF 【求割点Tarjan】

时间:2014-08-26 11:39:25      阅读:256      评论:0      收藏:0      [点我收藏+]

标签:poj1523

SPF
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6131   Accepted: 2814

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible. 

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate. 
bubuko.com,布布扣

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist. 

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets

Source

题意:给定一张图,求出所有割点以及去掉割点将图分成的块数。

题解:用Tarjan求割点,对于每个当前点u,若它能连接到非父节点v点,则更新low[u],若dfn[u]<=low[v],且u点不为根节点,则u点即为割点,vertex[u]==u点的子树个数+1,若u点是根节点,则当且仅当u的子树个数>1时u点为割点,分割块数为其子树的个数。

#include <stdio.h>
#include <string.h>
#define maxn 1002
#define maxm maxn * maxn
/*
** vertex[i]用来存储若i为割点时能将图分割的块数
** sec是时间戳
** dfn[]存储到达节点的时间
** low[]存储节点i能到达的最早节点的时间
** sta[]存储点双连通分支
*/
int head[maxn], id, cas = 1, vertex[maxn], sec;
int dfn[maxn], low[maxn], n, sta[maxn], id2;
struct Node{
    int to, next;
} E[maxm];

int max(int a, int b){
    return a > b ? a : b;
}

int min(int a, int b){
    return a < b ? a : b;
}

void initial()
{
    id = n = id2 = sec = 0;
    memset(head, -1, sizeof(head));
    memset(vertex, 0, sizeof(vertex));
    memset(dfn, 0, sizeof(dfn));
    memset(low, 0, sizeof(low));
}

void addEdge(int u, int v)
{
    E[id].to = v; E[id].next = head[u];
    head[u] = id++; E[id].to = u;
    E[id].next = head[v]; head[v] = id++;
}

void Tarjan(int pos, int father)
{
    dfn[pos] = low[pos] = ++sec;
    sta[id2++] = pos; int i;
    for(i = head[pos]; i != -1; i = E[i].next){
        if(E[i].to == father) continue; //过滤
        if(!dfn[E[i].to]){
            Tarjan(E[i].to, pos);
            low[pos] = min(low[pos], low[E[i].to]); //更新low
            if(dfn[pos] <= low[E[i].to]){
                while(sta[--id2] != E[i].to) ; //同一分支出栈
                ++vertex[pos]; //子树+1
            }
        }else low[pos] = min(low[pos], low[E[i].to]); //更新low
    }
}

void solve(int n)
{
    int i, u, v, ok = 0;
    Tarjan(1, 0); --vertex[1]; //根节点分支数要-1,输出时再+1
    printf("Network #%d\n", cas++);    
    for(i = 1; i <= n; ++i){
        if(vertex[i] > 0){
            printf("  SPF node %d leaves %d subnets\n", i, vertex[i] + 1);
            ok = 1;
        }
    }
    if(ok == 0) printf("  No SPF nodes\n");
    printf("\n");
}

int main()
{
    //freopen("stdin.txt", "r", stdin);
    int u, v; initial();
    while(scanf("%d%d", &u, &v) != EOF){
        n = max(u, n);
        n = max(v, n);
        if(0 == u){
            solve(n); if(!v) break;
            initial(); scanf("%d", &u);
            n = max(u, n);
        }
        addEdge(u, v);
    }
    return 0;
}


POJ1523 SPF 【求割点Tarjan】

标签:poj1523

原文地址:http://blog.csdn.net/chang_mu/article/details/38844447

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!