码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2155——Matrix(二维树状数组)

时间:2014-08-26 11:42:15      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   io   strong   for   ar   div   

Matrix
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 18460   Accepted: 6950

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a ‘0‘ then change it into ‘1‘ otherwise change it into ‘0‘). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1


————————————————————————分割线——————————————————


题目大意:

有一个n*n的矩形平面,里面每个点初始为0,有两种操作:

1.将左上角为(x1,y1),右下角为(x2,y2)的矩形区域中的每个点,把0变成1,把1变成0

2.查询点(x,y)当前的值


思路:

对于翻转矩形区域,一种是向上,一种向下,跟一维是类似的,辅助数组c[][]来记录修改次数


向上修改,向下统计:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,m;
int c[1010][1010];
void update(int x,int y)
{
    for(int i=x;i<=n;i+=i&-i){
        for(int j=y;j<=n;j+=j&-j){
            c[i][j]++;
        }
    }
}
int getsum(int x,int y)
{
    int sum=0;
    for(int i=x;i>0;i-=i&-i){
        for(int j=y;j>0;j-=j&-j){
            sum+=c[i][j];
        }
    }
    return sum;
}
int main()
{
    int T;
    cin>>T;
    while(T--){
        memset(c,0,sizeof(c));
        scanf("%d %d",&n,&m);
        getchar();
        while(m--){
            char ch;
            ch=getchar();
            if(ch=='C'){
                int x1,y1,x2,y2;
                scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
                getchar();
                update(x1,y1);
                update(x2+1,y2+1);
                update(x2+1,y1);
                update(x1,y2+1);
            }
            if(ch=='Q'){
                int x,y;
                scanf("%d %d",&x,&y);
                getchar();
                printf("%d\n",getsum(x,y)&1);
            }
        }
        if(T) printf("\n");
    }
    return 0;
}


向下修改,向上统计:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int n,m;
int c[1010][1010];
void update(int x,int y)
{
    for(int i=x;i>0;i-=i&-i){
        for(int j=y;j>0;j-=j&-j){
            c[i][j]++;
        }
    }
}
int getsum(int x,int y)
{
    int sum=0;
    for(int i=x;i<=n;i+=i&-i){
        for(int j=y;j<=n;j+=j&-j){
            sum+=c[i][j];
        }
    }
    return sum;
}
int main()
{
    int T;
    cin>>T;
    while(T--){
        memset(c,0,sizeof(c));
        scanf("%d %d",&n,&m);
        getchar();
        while(m--){
            char ch;
            ch=getchar();
            if(ch=='C'){
                int x1,y1,x2,y2;
                scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
                getchar();
                update(x2,y2);
                update(x1-1,y2);
                update(x2,y1-1);
                update(x1-1,y1-1);
            }
            if(ch=='Q'){
                int x,y;
                scanf("%d %d",&x,&y);
                getchar();
                printf("%d\n",getsum(x,y)&1);
            }
        }
        if(T) printf("\n");
    }
    return 0;
}


POJ 2155——Matrix(二维树状数组)

标签:des   style   color   os   io   strong   for   ar   div   

原文地址:http://blog.csdn.net/u014141559/article/details/38844371

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!