码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2001 计算两点间的距离

时间:2017-05-08 19:20:28      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:problem   desc   scanf   int   sam   import   while   algo   math   

Problem Description
输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。
 

 

Input
输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。
 

 

Output
对于每组输入数据,输出一行,结果保留两位小数。
 

 

Sample Input
0 0 0 1 0 1 1 0
 

 

Sample Output
1.00 1.41
 
分析:题目为简单的基础题,会运用sqrt开方函数。
 
AC源代码(C语言):
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <math.h>

int main()
{
    double a, b, c, d;
    double result;
    while(scanf("%lf %lf %lf %lf", &a, &b, &c, &d) != EOF){
        double x = (a-c) * (a-c);
        double y = (b-d) * (b-d);
        printf("%.2lf\n",sqrt(x+y));
    }
}

Java源代码:

import java.util.Arrays;
import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sin=new Scanner(System.in);
        while(sin.hasNextDouble()){
            double a, b, c, d;
            a = sin.nextDouble();
            b = sin.nextDouble();
            c = sin.nextDouble();
            d = sin.nextDouble();
            double x = (a-c) * (a-c);
            double y = (b-d) * (b-d);
            double result = Math.sqrt(x+y);
            String res = String .format("%.2f", result);
            System.out.println(res);
        }
    }
}

 

HDU 2001 计算两点间的距离

标签:problem   desc   scanf   int   sam   import   while   algo   math   

原文地址:http://www.cnblogs.com/hey-man/p/6826801.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!