码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3122 Pie 二分答案

时间:2014-05-09 06:33:22      阅读:343      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   二分   poj   

Pie
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9653   Accepted: 3478   Special Judge

Description

bubuko.com,布布扣My birthday is coming up and traditionally I‘m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though. 

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. 

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10?3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source


题解

题意是将,一哥们过生日,来了f个人,有n个披萨饼,这些披萨饼有着相同的厚度和各自的半径。然后这些哥们想吃披萨,每个人又想吃的都是一样的数量,而且不能大家都不想去吃用剩下的边角料留下的披萨,所以就问每个人吃披萨饼的最大量。

思路大概就是二分答案了。但是有个小问题就是精度。首先是PI,要不用C++的反三角函数去计算,要不就去网上找常量去计算。接着是误差限,一定要注意1e-5。最后一个就是提交问题了。我会回头再说明选择G++和C++的区别。

代码示例

/****
	*@author    Shen
	*@title     poj 3122
	*/

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;

const double PI = acos(-1.0);
const double eps = 1e-5;

int n, f;
double r, v[10005];
double maxa = 0;

bool test(double x)
{
    int sum = 0;
    for (int i = 0; i < n; i++)
        sum += int(v[i] / x);
    return sum >= (f + 1);
}

double Bsearch(double l, double r)
{
    while (r - l > eps)
    {
        double mid = (r + l) * 0.5;
        if (test(mid))
            l = mid;
        else r = mid;
    }
    return l;
}

void solve()
{
    scanf("%d%d", &n, &f);
    maxa = 0;
    for (int i = 0; i < n; i++)
    {
        scanf("%lf", &r);
        v[i] = r * r * PI;
        maxa = max(maxa, v[i]);
    }
    double ans = Bsearch(0.0, maxa);
    printf("%.4lf\n", ans);
}

int main()
{
    int t; scanf("%d", &t);
    while (t--)
        solve();
    return 0;
}

POJ 3122 Pie 二分答案,布布扣,bubuko.com

POJ 3122 Pie 二分答案

标签:acm   c++   二分   poj   

原文地址:http://blog.csdn.net/polossk/article/details/25345083

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!