码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2352 Stars

时间:2017-05-11 18:37:12      阅读:282      评论:0      收藏:0      [点我收藏+]

标签:nts   problem   poj 2352   blank   ant   pst   contain   mem   bool   

Stars

Time Limit: 1000MS   Memory Limit: 65536K

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

技术分享


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目大意:
  天文学家经常要检查星星的地图,每个星星用平面上的一个点来表示,每个星星都有坐标。我们定义一个星星的“级别”为给定的星星中不高于它并且不在它右边的星星的数目。天文学家想知道每个星星的“级别”。
技术分享
  例如上图,5号星的“级别”是3(1,2,4这三个星星),2号星和4号星的“级别”为1。
  给你一个地图,你的任务是算出每个星星的“级别”。
喜闻乐见的Code
#include<cstdio>
#include<algorithm>
using namespace std;
#define maxn 15010
struct BIT {
	int x,y;
	bool operator < (const BIT &a)const {
		if(x!=a.x) return x<a.x;
		return y<a.y;
	}
}p[maxn];
int t[32010],ans[maxn];
inline int input() {
	char c=getchar();int x=0,flag=1;
	for(;c<‘0‘||c>‘9‘;c=getchar())
		if(c==‘-‘) flag=-1;
	for(;c>=‘0‘&&c<=‘9‘;c=getchar())
		x=(x<<1)+(x<<3)+c-‘0‘;
	return x*flag;
}
inline int lowbit(int x) {
	return x&(-x);
}
void insert(int x) {
	for(;x<=32001;x+=lowbit(x))
		t[x]++;
	return;
}
int query(int x) {
	int ans=0;
	for(;x;x-=lowbit(x))
		ans+=t[x];
	return ans;
}
int main() {
	int n=input();
	for(int i=1;i<=n;i++) {
		p[i].x=input();p[i].y=input();
		p[i].x++;p[i].y++;
	}
	sort(p+1,p+n+1);
	for(int i=1;i<=n;i++) {
		int T=query(p[i].y);
		insert(p[i].y);
		ans[T]++;
	}
	for(int i=0;i<n;i++)
		printf("%d\n",ans[i]);
	return 0;
}

  

 

poj 2352 Stars

标签:nts   problem   poj 2352   blank   ant   pst   contain   mem   bool   

原文地址:http://www.cnblogs.com/NuclearSubmarines/p/6842070.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!