码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 1631 Bridging signals

时间:2017-05-14 18:56:28      阅读:289      评论:0      收藏:0      [点我收藏+]

标签:cte   ios   sign   first   jsb   size   poj   lis   uri   

Bridging signals

Description

‘Oh no, they‘ve done it again‘, cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

 

技术分享

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number specifies which port on the right side should be connected to the i:th port on the left side.Two signals cross if and only if the straight lines connecting the two ports of each pair do.

Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.

Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.

Sample Input

4
6
4 2 6 3 1 5
10
2 3 4 5 6 7 8 9 10 1
8
8 7 6 5 4 3 2 1
9
5 8 9 2 3 1 7 4 6

Sample Output

3
9
1
4

最长公共子序列。!!

!!!

因为p<=40000,使得传统的O(n*n)算法行不通了!

!!

这里推荐一种O(nlogn)算法。

技术分享


AC代码例如以下:

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

int dp[40005];
int a[40005];

int dich(int l,int r,int i)
{
    int mid;
    while(r>l)
    {
        mid = (l+r)/2;
        if(a[i]<=dp[mid]) r=mid;
        else l=mid+1;
    }
    return l;
}

int main()
{
    int i,j;
    int t;
    int n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(i=1;i<=n;i++)
            {
                cin>>a[i];
            }
            dp[1]=a[1];
            int top=1;
        for(i=2;i<=n;i++)
        {
            if(a[i]>dp[top])
            {
                dp[++top]=a[i];
            }
            else
            {
                int ans=dich(1,top,i);
                dp[ans]=a[i];
            }
        }
        cout<<top<<endl;
    }
    return 0;
}



POJ 1631 Bridging signals

标签:cte   ios   sign   first   jsb   size   poj   lis   uri   

原文地址:http://www.cnblogs.com/cxchanpin/p/6853166.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!