码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1094 Sorting It All Out (拓扑排序)

时间:2014-08-26 19:40:46      阅读:194      评论:0      收藏:0      [点我收藏+]

标签:des   style   color   os   使用   io   strong   for   ar   

Sorting It All Out
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 27929   Accepted: 9655

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.


思路:根据矛盾优先原则,即只要出现矛盾就结束程序,输出答案;然后再没有矛盾的基础上进行拓扑排序看能否得出它们之间关系;最后,若以上两者均没有结果,则是条件不足。同时,我们要输入一个关系进行一次判断。

在程序中,每次拓扑后若满足合法的拓扑条件,就记录答案。最后判断是否有矛盾关系即可。

#include"stdio.h"
#include"string.h"
#include"vector"
#include"queue"
#include"iostream"
#include"algorithm"
using namespace std;
#define N 1000
#define M 26
vector<int>g[M];     //记录拓扑关系
int pre[M],n,m,flag,t;
int mark[M];        标记字符是否出现及是否使用过
char ans[M+5];      记录答案
void top_sort(int k)
{
    t=k+1;             
    int i,j,u,v,tmp;
    queue<int>q;
    memset(pre,0,sizeof(pre));
    memset(mark,0,sizeof(mark));
    for(i=0;i<n;i++)
    {
        if(g[i].size()!=0)
            mark[i]=1;        //等于1代表该字符出现
        for(j=0;j<g[i].size();j++)
        {
            v=g[i][j];
            mark[v]=1;
            pre[v]++;
        }
    }
    j=0;
    while(1)
    {
        tmp=0;
        for(i=0;i<n;i++)
        {
            if(pre[i]==0&&mark[i]==1)
            {
                mark[i]=-1;      //字符已经用过一次
                u=i;         
                q.push(u);
                tmp++;
            }
        }
        if(tmp==0)       //排序结束标志
            break;
        else if(tmp==1) //条件合法,记录答案
            ans[j++]='A'+u-0;
        while(!q.empty())
        {
            u=q.front();
            q.pop();
            for(i=0;i<g[u].size();i++)
            {
                v=g[u][i];
                pre[v]--;
            }
        }
    }
    for(tmp=i=0;i<n;i++)
        if(pre[i])
            tmp++;
    if(tmp>0)      //出现该情况肯定是出现矛盾 
        flag=2;
    else if(j==n)
        flag=1;
    ans[j]='\0';
}
int main()
{
    char s[10];
    int i,u,v;
    while(scanf("%d%d",&n,&m),n||m)
    {
        flag=0;
        for(i=0;i<M;i++)
            g[i].clear();
        for(i=0;i<m;i++)
        {
            scanf("%s",s);
            if(!flag)
            {
                u=s[0]-'A';
                v=s[2]-'A';
                g[u].push_back(v);
                top_sort(i);        //进行拓扑排序
            }
        }
        if(flag==1)
            printf("Sorted sequence determined after %d relations: %s.\n",t,ans);
        else if(flag==2)
            printf("Inconsistency found after %d relations.\n",t);
        else
            printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}


poj 1094 Sorting It All Out (拓扑排序)

标签:des   style   color   os   使用   io   strong   for   ar   

原文地址:http://blog.csdn.net/u011721440/article/details/38852215

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!