码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1018 Big Number n!的位数

时间:2017-05-17 21:31:39      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:style   time   ...   答案   mission   hdu1018   appear   namespace   case   

Big Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31053 Accepted Submission(s): 14398


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2 10 20

Sample Output
7 19
一个整数n的位数:log10(n)+1
此题答案为:log10(n!)+1.
log(n!)=log(n)+log(n-1)+log(n-2).....+log(1)
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;

int main()
{
    int i,j,n,T,res;
    double t;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        t=0;
        for(i=1;i<=n;i++)
            t+=log10(i);
        res=(int)t+1;
        printf("%d\n",res);
    }
    return 0;
}


HDU1018 Big Number n!的位数

标签:style   time   ...   答案   mission   hdu1018   appear   namespace   case   

原文地址:http://www.cnblogs.com/gccbuaa/p/6869580.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!