码迷,mamicode.com
首页 > 其他好文 > 详细

HDU5014 Game(尼姆博弈)

时间:2017-05-17 22:08:34      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:简单   main   scan   begin   inner   div   input   游戏   iss   

Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 493    Accepted Submission(s): 380


Problem Description
Here is a game for two players. The rule of the game is described below:

● In the beginning of the game, there are a lot of piles of beads.

● Players take turns to play. Each turn, player choose a pile i and remove some (at least one) beads from it. Then he could do nothing or split pile i into two piles with a beads and b beads.(a,b > 0 and a + b equals to the number of beads of pile i after removing)

● If after a player‘s turn, there is no beads left, the player is the winner.

Suppose that the two players are all very clever and they will use optimal game strategies. Your job is to tell whether the player who plays first can win the game.
 


Input
There are multiple test cases. Please process till EOF.

For each test case, the first line contains a postive integer n(n < 105) means there are n piles of beads. The next line contains n postive integer, the i-th postive integer ai(ai < 231) means there are ai beads in the i-th pile.
 


Output
For each test case, if the first player can win the game, ouput "Win" and if he can‘t, ouput "Lose"
 


Sample Input
1 1 2 1 1 3 1 2 3
 


Sample Output
Win Lose Lose
 
分析:尼姆博弈题,虽然稍微有点不同,但可以忽略
这里引用一下关于尼姆博弈的简单说法:
尼姆博弈:

指的是一个游戏,目前有任意堆石子,每堆的石子都是任意的,双方轮流从中取石子,有如下规则:

1,每一步只能从某一堆取走至少一枚石子;

2,谁取到最后一次石子,谁胜利。

结论:假设有n堆物品,每堆物品有a[i]件,若a[0]^a[1]^a[2]^........a[n-1]!=0 先手必胜,否则必败。

#include <cstdio>
#include <iostream> 
using namespace std;
typedef long long ll;
int c[1000010];
int main()
{
	int n,ans;
	while(scanf("%d",&n)!=EOF)
	{
		ans=0;
		for(int i=0;i<n;i++)
		{
		  scanf("%d",&c[i]);	
		  ans=ans^c[i];
	    }
		if(ans!=0)
		puts("Win");
		else
		puts("Lose");
	}
	return 0;
}

  

HDU5014 Game(尼姆博弈)

标签:简单   main   scan   begin   inner   div   input   游戏   iss   

原文地址:http://www.cnblogs.com/a249189046/p/6869662.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!